Percona Xtrabackup on Suse EL 10 — Failing

Posted on

Question :

I have evaluated Percona Xtrabackup successfully and it works like a charm on my several CentOS / RHEL servers! Hats off to the team!

But my problem starts when I tried to install this on one of my client’s Suse EL 10 server. I believe Xtrabackup is not natively supported on Suse. But being an RPM based platform, I tried installing RHEL5 rpms from percona site. But they don’t work. They install (a fairly older version 1.5.x) but when run they throw the error like

Command I am running : /usr/bin/innobackupex –ibbackup=xtrabackup –defaults-file=/etc/my.cnf –user=some_user –password=password /root/backups

Error shown is : innobackupex: fatal error: no ‘mysqld’ group in MySQL options

I have made sure that my.cnf exist, it contains all necessary parametes like datadir / log files related parameters.

See if you can help me with this and let me know if you need any more help / logs that I can provide.

Answer :

I guess you are under a wrong impression that it is a OS related issue.
Check your server bit if it is 32 bit and if you try to install 64bit package percona’s xtrabackup . It would end up throwing such error messages.

What versions of MySQL and Percona Xtrabackup are you running?

This error can occur when you use a recent version of Percona Xtrabackup that has discontinued support for the old version of MySQL you are running.

Specifically, see http://www.percona.com/doc/percona-xtrabackup/2.1/release-notes/2.1/2.1.0-alpha1.html

Support for InnoDB 5.0 and InnoDB 5.1 builtin has been removed from Percona XtraBackup.

Leave a Reply

Your email address will not be published. Required fields are marked *